The issue has been resolved and delivery service continues in all countries. Thanks for your continued patience π
Posted Sep 18, 2026 - 11:51 EEST
Update
π₯οΈ Things are looking up
Our team is actively keeping an eye on things to make sure everything stays that way. Thanks so much for your patience π
Posted Sep 18, 2026 - 11:45 EEST
Monitoring
π± Back on our feet
The delivery service continues in Georgia. Thanks for your continued patience π
Posted Sep 18, 2026 - 11:39 EEST
Update
π§ Temporary Pause on Deliveries
We've temporarily paused deliveries in the following areas due to Card payment failures:
Georgia π¬πͺ
We'll restart deliveries as soon as things are back to normal. Our next update will be posted as soon as possible. Thanks for your patience and understanding π
Posted Sep 18, 2026 - 11:31 EEST
Investigating
π¨ Service Alert
Hi there! We're currently looking into an issue that may be affecting payments in:
Georgia
Users may experience card payment failures.
Our team is on it, and we'll share an update here as soon as possible. Thank you for your patience! π
Posted Sep 18, 2026 - 11:29 EEST
This incident affected: Consumer Operations (Consumer Apps).