Merchant Portal and Merchant App Lite issues

Incident Report for Wolt

Resolved

🌱 Back on our feet

The issue has been resolved and delivery service continues in all countries. Thanks for your continued patience. πŸ’™
Posted Mar 20, 2026 - 14:33 EET

Monitoring

πŸ–₯️ Things are looking up

We've applied a fix and the situation seems stable now. Our team is actively keeping an eye on things to make sure everything stays that way. Thanks so much for your patience πŸ™
Posted Mar 20, 2026 - 14:26 EET

Update

πŸ”¨ We're on it

We have applied a fix. We see Merchant Portal has recovered. We are monitoring the situation in the meantime. System performance is expected to gradually normalize back to normal. Next update in 10 minutes πŸ™
Posted Mar 20, 2026 - 14:19 EET

Identified

πŸ”§ We've found the issue

We've identified the cause of the problem affecting merchant portal and merchant app and are now working on a fix. We see slight recovery already.

We'll share another update as soon as possible. Thanks for sticking with us πŸ’™
Posted Mar 20, 2026 - 14:06 EET

Update

πŸ” We're still looking into it

Our team is continuing to investigate the issue affecting Merchant Admin & Merchant App.

We'll share another update here as soon as possible. Thanks for bearing with us. πŸ™
Posted Mar 20, 2026 - 13:47 EET

Investigating

πŸ” We're still looking into it

Our team is continuing to investigate the issue affecting Merchant Admin & Merchant App.

We'll share another update here as soon as possible. Thanks for bearing with us. πŸ™
Posted Mar 20, 2026 - 13:32 EET
This incident affected: Merchant Operations (Merchant App, Merchant Admin).