Errors with task acceptance and estimations

Incident Report for Wolt

Resolved

This incident has been resolved.
Posted Oct 31, 2025 - 15:11 EET

Update

We are continuing to investigate this issue.
Posted Oct 31, 2025 - 14:51 EET

Investigating

We are currently investigating this issue.
Posted Oct 31, 2025 - 14:46 EET
This incident affected: Consumer Operations (Consumer Apps) and Courier Operations (Courier App).